Issues with Inbound Email Services
Incident Report for AnswerFirst
Resolved
We have found and corrected the issue that was causing interruption of inbound emails. All services are restored. We sincerely apologize for any inconvenience this may have caused.
Posted 21 days ago. May 30, 2019 - 15:25 EDT
Identified
We are investigating reports of an issues with inbound emails. Not all accounts are being affected. Our IT Team is investigating this issue and we will have an update within 4 hours. We apologize for any inconvenience this may be causing.
Posted 21 days ago. May 30, 2019 - 14:35 EDT
This incident affected: Email Services.