Email Services Resolution
Incident Report for AnswerFirst
Resolved
We have found and corrected the issue that was causing interruption of sending and/or receiving emails. All services are restored. We sincerely apologize for any inconvenience this may have caused.
Posted 3 months ago. Aug 31, 2017 - 20:33 EDT
Monitoring
We have found and corrected the issue that was causing interruption of sending and/or receiving emails. All services are restored. We sincerely apologize for any inconvenience this may have caused.
Posted 3 months ago. Aug 31, 2017 - 19:59 EDT