Email Services Issues
Incident Report for AnswerFirst
Resolved
We have found and corrected the issue that was causing interruption of sending and/or receiving emails. All services are restored. We sincerely apologize for any inconvenience this may have caused.
Posted 2 months ago. Oct 11, 2018 - 04:26 EDT
Identified
We have identified an issue that is causing the failure in sending and/or receiving emails. Our IT Team is working to resolve this issue. We will have an update within 4 hours. We apologize for any inconvenience this is causing.
Posted 2 months ago. Oct 11, 2018 - 00:10 EDT
This incident affected: Email Services.