Faxing Services Issues
Incident Report for AnswerFirst
Resolved
Our fax provider has resolved this issue. We are now receiving faxes once again.
Posted Jun 16, 2019 - 01:31 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 15, 2019 - 20:45 EDT
Identified
We have identified an issue that is causing the failure in receiving faxes. Our IT Team is working to resolve this issue. We will have an update within 4 hours. We apologize for any inconvenience this is causing.
Posted Jun 15, 2019 - 20:44 EDT