Weather related call volume issues
Incident Report for AnswerFirst
Resolved
Our call center call volume has resumed normal volume and wait times. We sincerely apologize for any inconvenience this may have caused.
Posted Dec 25, 2022 - 20:56 EST
Identified
Weather related call volume is significantly impacting wait times. We are doing everything we can to increase staffing and handle the volume as fast as possible.
Posted Dec 24, 2022 - 10:38 EST
Investigating
We are currently experiencing high call volume due to the extreme weather conditions impacting much of the country. We appreciate your patience and understanding while we work to increase our staffing. Thank you.
Posted Dec 24, 2022 - 10:34 EST
This incident affected: Voice Services.