Weather related call volume issues
Incident Report for AnswerFirst
Resolved
Call volume has been reduced to normal levels. We appreciate your patience and partnership.
Posted Dec 28, 2022 - 10:41 EST
Identified
We are currently experiencing high call volume due to the extreme weather conditions impacting much of the country. We appreciate your patience and understanding while we work to increase our staffing. Thank you.
Posted Dec 26, 2022 - 09:55 EST
This incident affected: Voice Services.