Faxing Services Issues
Incident Report for AnswerFirst
Resolved
We have found and corrected the issue that was causing interruption of sending faxes. We are currently running on our backup system and all services are restored. We sincerely apologize for any inconvenience this may have caused.
Posted 3 months ago. Oct 04, 2018 - 11:46 EDT
Identified
We have identified an issue that is causing the failure in sending faxes. Our IT Team is working to resolve this issue. We will have an update within 4 hours. We apologize for any inconvenience this is causing.
Posted 3 months ago. Oct 04, 2018 - 11:37 EDT
This incident affected: Faxing Services.