Hurricane Dorian
Incident Report for AnswerFirst
Resolved
This incident has been resolved.
Posted Oct 15, 2019 - 15:12 EDT
Monitoring
"Please know that we are keeping a close eye on Dorian. Because our Contact Center Staff and all Equipment are located across the United States, we do not anticipate any issues other than an increase in call volume from our Florida clients impacted by Dorian. We will continue to make staffing adjustments as is needed.

Depending on Dorian's path, our headquarters may be impacted. As such, we ask for your patience as there may be a delay in responding to issues that fall outside of handling your calls.

We will continue to update our alert system with new information as it becomes available. To stay in the loop we ask that you subscribe to it by visiting: status.answerfirst.com

Thank you for your understanding. To those in Dorian's path, we urge you to take the proper precautions."
Posted Aug 29, 2019 - 12:52 EDT