Hurricane Idalia
Incident Report for AnswerFirst
Resolved
While we continue to monitor Hurricane Idalia, our operations and call volume remain at normal levels. Thank you.
Posted Aug 30, 2023 - 13:24 EDT
Monitoring
We are closely tracking Hurricane Idalia's trajectory as it approaches the Florida Coast. While we anticipate no disruptions to our operations, we do anticipate a rise in call volume as our Florida partners take precautionary measures, including closing early. We appreciate your understanding in advance and will keep you informed with updates as the situation evolves.
Posted Aug 29, 2023 - 11:48 EDT
This incident affected: Voice Services.