Voice Service outage. Vitelity forwarding numbers not working.
Incident Report for AnswerFirst
Resolved
Our vendor Vitelity has found and corrected the issue that was causing the interruption of voice services. All services are restored. We sincerely apologize for any inconvenience this may have caused.
Posted Apr 06, 2021 - 11:48 EDT
Identified
We are currently experiencing intermittent voice service issues at our call center. Please note that some accounts might not be affected by this service outage. Our voice carrier for some accounts, Vitelity, is reporting nationwide issues. Our IT Department is working to address the issues and will bring our service back online ASAP. We will post a follow-up message as soon as service is fully reinstated.

We sincerely apologize for this inconvenience and thank you for your understanding.
Posted Apr 06, 2021 - 11:23 EDT
This incident affected: Voice Services.