Possible Voice Service disruption.
Incident Report for AnswerFirst
Resolved
Our carrier reports that they have found and corrected the issue that was causing interruption of voice services. All services are restored. We sincerely apologize for any inconvenience this may have caused.
Posted Sep 22, 2021 - 14:30 EDT
Investigating
Our carrier has advised us that they are experiencing voice service issues. Some customers may be affected. Our IT Department is working to address the issues. We will update this issue within 4 hours with any updates.
Posted Sep 22, 2021 - 12:59 EDT
This incident affected: Voice Services.