Issues with Email Services
Incident Report for AnswerFirst
Resolved
Our IT team has identified the issue and fixed it. All email services are back to fully operational.
Posted 3 months ago. Jun 13, 2019 - 07:49 EDT
Investigating
We are investigating reports of an issues with sending and/or receiving emails. Not all accounts are being affected. Our IT Team is investigating this issue and we will have an update within 4 hours. We apologize for any inconvenience this may be causing.
Posted 3 months ago. Jun 13, 2019 - 06:58 EDT
This incident affected: Email Services.