The "Billing and Payments" page is not loading.

Incident Report for AnswerFirst

Resolved

A fix has been implemented. Clients can now access their billing and payment portal.
Posted Aug 21, 2025 - 22:51 EDT

Identified

We have identified the issue and you can now access your Billing and Payment page in Client Web Access.
Posted Aug 21, 2025 - 19:07 EDT

Investigating

The "Billing and Payments" page is not loading. We are currently diagnosing the issue.
Posted Aug 21, 2025 - 18:34 EDT
This incident affected: Client Billing Portal.