MiSecure Services Issue
Incident Report for AnswerFirst
Resolved
We have found and corrected the issue that was causing interruption of sending and/or receiving MiSecure Messages. All services are restored. We sincerely apologize for any inconvenience this may have caused.
Posted Jun 24, 2021 - 14:00 EDT
Identified
We have identified an issue that is causing the failure in sending and/or receiving some MiSecure Messages. Our IT Team is working to resolve this issue. We will have an update within 4 hours. We apologize for any inconvenience this is causing.
Posted Jun 24, 2021 - 12:08 EDT
This incident affected: MiSecure Services.