Faxing Services Issues
Incident Report for AnswerFirst
Resolved
We have found and corrected the issue that was causing interruption of sending and/or receiving faxes. All services are restored. We sincerely apologize for any inconvenience this may have caused.
Posted 20 days ago. Aug 31, 2017 - 14:59 EDT
Monitoring
We have found and corrected the issue that was causing interruption of sending and/or receiving faxes. All services are restored. We sincerely apologize for any inconvenience this may have caused.
Posted 20 days ago. Aug 31, 2017 - 13:59 EDT