Faxing Services Issues
Incident Report for AnswerFirst
Resolved
We have found and corrected the issue that was causing interruption of sending and/or receiving faxes. All services are restored. We sincerely apologize for any inconvenience this may have caused.
Posted 11 months ago. Dec 12, 2017 - 11:00 EST
Investigating
We are investigating reports of an issues with sending and/or receiving faxes. Not all accounts are being affected. Our IT Team is investigating this issue and we will have an update within 4 hours. We apologize for any inconvenience this may be causing.
Posted 11 months ago. Dec 12, 2017 - 09:23 EST